Sorry, we don't support your browser.  Install a modern browser

Can't Open App#8

I am getting a message, “This software needs to be updated. Contact the developer for more information.

This software needs to be updated. Contact the developer for more information.”

Can you please help? Thank you

7 months ago

Hey Angelica, which version of MacOS are you on?

7 months ago
?

Catalina

7 months ago
Changed the status to
Archived
6 months ago

Hi Jordan - sorry I missed your last reply. I’m on 10.15.1

6 months ago

Angelica - This should be fixed now! Please download the newest version from https://getslash.co/download

6 months ago